Kameleoon Main Application Tools Temporarily Unavailable

Incident Report for Kameleoon

Postmortem

Date: August 23–24, 2025
Duration: ~22 hours (from 08:37 AM EST on Aug 23 to 06:28 AM EST on Aug 24)
Impact:
On August 23, customers began experiencing intermittent login issues starting at 08:37 AM EST. This escalated into a full outage of the login service, during which users were unable to access the platform. No customer data was lost or compromised.
Cause:
The incident was triggered by a hardware failure on one of our infrastructure nodes. During the recovery process, one of the services responsible for authentication was unintentionally placed on an environment where it could not properly access its storage. This caused our authentication system to become unavailable, leading to login failures.
Resolution:
Our engineering team:

  • Removed the faulty infrastructure node from the cluster.
  • Restored the authentication service to a healthy environment.
  • Verified full restoration of login functionality.

All services were back online by 06:28 AM EST on August 24.
Next Steps & Prevention:
To prevent similar incidents, we are:

  • Improving safeguards to ensure critical services are always deployed in the correct environments.
  • Enhancing monitoring to detect service misplacements and storage access issues more quickly.

We apologize for the disruption this caused. Ensuring reliability and uninterrupted access is our highest priority, and we are implementing stronger controls to prevent this type of incident in the future.

Posted Aug 25, 2025 - 17:55 CEST

Resolved

This incident has been resolved.
Posted Aug 24, 2025 - 12:28 CEST

Identified

We are currently investigating an issue affecting the availability of the Kameleoon back-office application (app.kameleoon.com). Our team is actively working to identify and resolve the issue as quickly as possible.

We apologize for any inconvenience this may cause and appreciate your patience.
Posted Aug 23, 2025 - 22:14 CEST
This incident affected: Campaign Management (core service) (app.kameleoon.com (back-office)).