[Scheduled] Technical Maintenance: Domain Whitelist Update

Scheduled for Dec 15, 07:00 - 07:15 CET

Update

Note that these changes do not affect running experiments in any way. The new domains are used to ensure Kameleoon functions properly for users who log in to app.kameleoon or use visual editors, especially in cases where ad blockers prevent these tools from working correctly.
Posted Nov 14, 2025 - 15:42 CET

Scheduled

On Monday, December 15 at 7:00 AM CET, we will release updates to our Kameleoon domain URLs.

If you have whitelisted Kameleoon domain URLs, for example in your Content Security Policy (CSP), please update your whitelists to ensure all features continue working correctly.

1. If you are using a wildcard pattern, please update your 'default-src' directive by adding: https://*.experimentation.dev

2. If you are using an explicit whitelist of URLs, please add the following new URLs to your CSP:
- https://static.experimentation.dev (script, style, connect, img, frame)
- https://sdk-config.experimentation.dev (connect)
- https://eu-data.experiment.dev (connect)

The following URLs will no longer be required after the update and can be removed from your CSP:
- https://static.kameleoon.com
- https://graphical-editor.kameleoon.com
- https://simulation.kameleoon.com
- https://aibuilder.kameleoon.com
- https://logger.kameleoon.io

If you need assistance with these updates, our team is available to help!
Posted Nov 14, 2025 - 00:25 CET
This scheduled maintenance affects: Campaign Management (core service) (app.kameleoon.com (back-office), Prompt-based Editor, Graphic Editor (incl. Widget Studio), Preview and Simulation).