Unable to delete stopped experiments
Incident Report for Kameleoon
Resolved
This incident has been resolved.
Posted 8 months ago. Oct 01, 2018 - 09:44 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 8 months ago. Sep 13, 2018 - 10:25 UTC
Investigating
We are currently investigating this issue.
Posted 8 months ago. Sep 13, 2018 - 08:51 UTC
This incident affected: A/B.